catalina 文件夹访问权限问题


#1

MacOS Catalina 通过终端启动的emacs 可以访问 Documents Downloads等文件夹,当从Applications下面的Emacs.app打开却不行


#2

emacs一直放在brew默认安装路径下的,没问题


#3

我挪动到Applications下面去了,不然启动的时候通过Spotlight找不到好像


#4

换了种做法,brew install emacs-plus 然后创建link 到 Applications下面


#5

同遇到这样的问题…… 楼主解决了吗?


#6

我是重装了emacs-plus,然后 ln 到 Applications下面


#7

brew cask reinstall emacs,也就是emacs 26.3 的版本,然后将Emacs.app/Applications/移动到/usr/local/Caskroom/emacs/26.3/,再再/Applications里面创建一个ln,但是从GUI这边启动依然不行,只能从terminal这边启动才可以,在Privacy里面设置了 Full Disk Access也没用……


#8

卸载 brew cask uninstall emacs, brew tap d12frosted/emacs-plus, 安装,选中emacs自带的icon,我觉得比较好看 brew install emacs-plus --without-spacemacs-icon, ln -s /usr/local/opt/emacs-plus/Emacs.app /Applications


#9

我刚刚又试了一遍,可以的,而且会弹出是否允许访问 Document,Download等文件夹


#10

可以了,虽然没有弹出是否允许访问 Document,Download等文件夹,但是总算可以了,感谢楼主。


#11

共同探讨,共同学习


#12

Security & Privacy 设置下权限就好了。。。 话说大家都升级了啊,很快嘛


#13

转一个帖子,亲自尝试成功。 安全性和隐私->选择全部磁盘权限->点开锁->输入密码->点右边的加号->按shift+cmd+. -> 选择/usr/bin/ruby

  • Go to “System Preferences -> Security & Privacy -> Privacy”
  • Select Full Disk Access from the left menu. It is about half way down in the menu. A list of apps will appear in the main region of the window.
  • Click the lock on the lower left and authenticate in order to allow making changes.
  • Click the + button under the list of software and select /usr/bin/ruby .
    • /usr is usually a hidden folder and may not appear by default. If so, press shift+cmd+. (the last one is a dot) at the root directory to make it appear.

#14

这个挺好,感谢分享


#15

直接给 full disk access 啊~~


#16

Emacs 给了 Full Disk Access 后,可以写文件到 Document 文件夹,但却看不到 Document 文件夹里已经存在的文件。怎么解?另外,自己在 HOME 下建的目录却可以访问到里面已经存在的文件。


#17

我刚开始直接就给了,然而并不能访问


#18

可以参考下 eddiedomain 的做法


#19

这个做法很棒,治标又治本…… 另外,岔开下话题,有人在Mac OS升级以后出现过emacs闪退吗? 一天之内已经出现两次了,之前运行几十天都没有出现过


#20

还没碰到过,用的emacs-plus