Win10下emacs26与latex配合使用的问题

我想在win10下使用emacs26.3对latex写作进行配置。过去有过的方案是auctex与cdlatex。但是很遗憾,前者在list-packages里面消失了,而后者可以安装但是提示缺少texmathp。想问问大家对于emacs+latex的写作有什么自己的方案么? 新手: )

我用的是很古老的auctex的版本(放在local), 也是emacs26 + win10, 完全没问题.

1赞

用Emacs编辑LaTeX,AucTeX是不二选择。

AucTeX你看不到了是因为它只在gnu源里,melpa里是没有的(因为没必要重复啊)。你把gnu源加到里的package-archives里就好了(默认本来就有的,一定是你自己整个清掉(比如setq了下它)又重定义了)

GNU源:

("gnu"   . "http://elpa.gnu.org/packages/")

比如我用的如下:(我也是重定义了一下,因为有段时间https不工作了导致报错,默认的gnu是https的)

(setq package-archives
      '(("gnu"   . "http://elpa.gnu.org/packages/")
        ("melpa" . "http://melpa.milkbox.net/packages/")))

注意,这个一定要放在(require 'package)之后,(package-initialize)(package-refresh-contents)之前。

1赞