搬家到 doom emacs 未果

在下目前是 Spacemacs 用户(小白),种草 doom emacs 一阵子以后终于试着搬家过去了。

先是照着 README 下载,make install,然后有很多包似乎因为版本不对安装不上,出现类似这样的错误:

Installing ox-reveal
FATAL ERROR: (error) Need package ‘org-20150330’, but only 9.1.7 is available

上网搜索一下,过往也有人遇到类似问题,作者的建议是切到 develop 分支,于是我也切了过去。

插件安装一切顺利,然而启动 Emacs 时变成这样了:

这都啥玩意儿呀 :joy:

本来觉得会很省心的,结果还没开始就变成这样,有点累觉不爱 :joy:

珍爱生命,远离折腾。。。。

需要执行一次 make autoloads

我觉得「用 Spacemacs」这件事就挺折腾的 :joy: 每次加个新 layer 都要读一遍它的代码,然后在私人配置层里面各种 post-init 或者索性写个新 layer,不然各种坑坑坑,所以想换个不折腾的配置而已。doom 看起来水平很高,应该能让我消停个一两年的吧 :joy:

啊原来是这样啊!真是谢谢你了 :joy: 怪我没有仔细看 README

我的配置绝大部分抄袭centaur-emacs,挺好用的,我喜欢!

谢谢推荐哈,等咱学懂了 elisp 也来借鉴借鉴(

spacemacs 挺好的啊,开箱即用,文档全面,而且用的人多,很多问题翻翻 issue 列表就能找到解决方案。

1 个赞

切换branch/更新emacs版本/git pull -rebase 之后请务必 make U

1 个赞

你说的也是哈,不过坑还是多,比较吃时间 :joy:

原来还有这样的讲究啊,谢谢提醒

这位坛友,请摸着你的胖友IM再说一遍。。

1 个赞

求问胖友是指啥

未果,寻病终 :roll_eyes:

2 个赞

噗原来是这个

我习惯撸cnfonts

doom-emacs 现在master基本是broken状态,切develop才能用。并且文档对不上,目前是个过渡期,非常多的breaking changes在develop branch. 希望尽快merge,并且update文档。不过目前我已经将develop branch 打通可用。如果等不及可以交流一下。

欢迎来discord doom-emacs channel 聊天 https://discord.gg/bcZ6P3y

顺便推销一发配置hhh https://github.com/fuxialexander/doom-emacs-private-xfu

2 个赞

是这样啊 :joy: 谢谢你哈,不过在下自从说要搬家以来都好忙,还没开始折腾 :joy: