传闻已久的 spacemacs 0.300 终于不远了 (develop 用户注意)

老是跟着上游跑确实挺累的。。。。。。

直接SPC f e D查看你的配置跟最新的配置template的diff就可以了,不用重新生成。

我自己撸了一个配置了。不过从您这里学到很多好东东。特别感谢一下。

你应该称呼 “道友” 。。。

1赞

道友切磋,理应如此 :joy:

已经用上0.300,谢谢

skill get

支持支持!又想要回到Spacemacs的怀抱中了

谢谢的提醒。 @zilongshanren 也许是使用 develop 分支的用户会遇到这个问题,变量 configuration-layer–elpa-archives 改成 configuration-layer-elpa-archives 。能否可在 https://elpa.emacs-china.org/ 标注下呢?

你可以直接提PR呀

1赞

我今天(11月29日)更新后发现了一个参数dotspacemacs-use-spacelpa,此值不为nil时会安装Spacelpa里面的包,为nil时安装MELPA的包。这个值默认为nil,不会安装Spacelpa里的包

今天手贱,emacs上26。然后又一个手贱 git pull 了新spacemacs,主题配置什么的都没了…然后要重新下100来个包。

好像新版本不能用elpa-china了,proxifier重新下载解决问题。

2020快结束的github上还没出现release0.300, :crazy_face:

2赞

看develop一直在更新!

1赞

develop已经是default了

17 年的的 0.300 :rofl:

我猜作者跟 magit 的作者一样,已经懒得打版本号了😂

作者感觉已弃坑了

刚刚去 GitHub 上的 spacemacs 页面看了一眼,感觉这个项目几乎是名存实亡了。这么复杂的项目一旦作者不维护了后来者感觉很难接手,也不知道 doom-emacs 能坚持到几时

就算doom作者弃坑了,后续维护直接用doom提供的函数也会轻松很多.

spacemacs抽象了一层layer,现在看来非常麻烦.

1赞