package升级找不到

我的package显示有6个可升级。升级时候报错:

package–with-response-buffer-1: http://elpa.emacs-china.org/melpa/pyim-20220130.722.tar: Not found 这个package不存在吗?

我关闭emacs的时候会报错:

save-buffers-kill-emacs: Wrong type argument: window-live-p, #<window 15>

我的melpa设置好像重复了。把哪个删了好?

 (setq package-archives '(("gnu"   . "http://elpa.emacs-china.org/gnu/")
                       ("melpa" . "http://elpa.emacs-china.org/melpa/")))

(require 'package) (add-to-list 'package-archives '(“melpa” . “Package Listing”) t)

就是关闭emacs的时候老是出现epc server 2。这是个啥玩意?

删第二个

(require 'package)
(add-to-list 'package-archives '(“melpa” . “Package Listing”) t)

我把这个删了,更新安装完了。 :grinning_face_with_smiling_eyes:

("melpa" . "http://elpa.emacs-china.org/melpa/")

你是不是装了 eaf?

这个是退出Emacs提示你 是否要结束这些进程的,按 y 就行了

melpa 源里也有软件包的…:joy:

你删了这行就无法使用 emacs-china melpa 源里的软件包了

按y没用,我安装了eaf但是用不了。必须点 epc server 2,出来一个新buffer。然后把那个buffer杀掉才能退出。难道要删了eaf?

我没有这个问题唉,你是照着README安装的吗?

没太看懂,能发一个GIF吗?

我是按照这个网站上的方法安装的:gitee

用不了这种表述太过模糊,你是不是无法正常使用eaf浏览网页等功能?

如果是的话,检查一下有没有安装PyQt5

PyQt5装了,但还是啥都打不开

https://github.com/manateelazycat/emacs-application-framework 安装

有报错信息吗?

从github上装不了,总是下载中断,只能从gitee上装

gitee上的可能不是最新,我记得不是最新版本的eaf有一定机率不能正常运行

你可以:

  1. git clone https://github.com.cnpmjs.org/manateelazycat/emacs-application-framework
  2. cd emacs-application-framework
  3. ./install-eaf.py --use-gitee
  4. 配置你的eaf

还是老样子。

az…

有报错信息吗?

说一下你的安装步骤,谢谢

安装过程中有几个warning,就是按照你说的装的。

你这么描述,没人能帮你,安装不了,无法使用,都是无效信息。

你要给出详细的步骤,不然没法重现。

打开 toggle-debug-on-error,贴出错信息。 打开 eaf buffer,贴出错信息。 贴安装 eaf时的 warning 信息。

1 个赞

我录了一段视频

[百度网盘](链接: 百度网盘 请输入提取码 )

eaf buffer里的:

Traceback (most recent call last): File “/home/unicorn/.emacs.d/emacs-application-framework/eaf.py”, line 25, in Traceback (most recent call last): File “/home/unicorn/.emacs.d/emacs-application-framework/eaf.py”, line 25, in from PyQt5 import QtWebEngineWidgets as NeverUsed # noqa ImportError: cannot import name ‘QtWebEngineWidgets’ from ‘PyQt5’ (/usr/local/lib/python3.8/site-packages/PyQt5/init.py) from PyQt5 import QtWebEngineWidgets as NeverUsed # noqa ImportError: cannot import name ‘QtWebEngineWidgets’ from ‘PyQt5’ (/usr/local/lib/python3.8/site-packages/PyQt5/init.py)

Process eaf exited abnormally with code 1

Process eaf<1> exited abnormally with code 1