ox-hugo导出到hugo时,以中文符号或汉字为行尾,导致不换行问题,如何解决?

在org中,以中文字符为行尾时,ox-hugo导出md,变成一行:

org

导出后,hugo中显示:

我现在是做法是每段之间再单独空一行空白行。 :stuck_out_tongue_closed_eyes:

我是把键盘在中文输入法的标点符号默认设置为半角模式,导致在其他app中中文输入法也是半角符号,体验很不好。

如何设置emacs-rime,在汉字和半角符号组合使用?

这个不是 emacs-rime 控制的,是rime 控制的。你按 Ctrl + ~ 就可以调出你的方案,进行切换了。

请问这个问题解决了吗,我也遇到这样的问题了

用hugo现在直接支持org-mode的啊,为什么还要转为markdown?

https://emacs.stackexchange.com/questions/21556/org-mode-export-how-to-force-newline-on-lines-between-paragraphs

#+OPTIONS: \n:t

之前尝试过这种方式,但是在中文字符结尾情况下,不起作用。

我这边试了下用内置的 export 中文没有问题。

加空行,在 markdown 的语法中,段落是需要空行的。

markdown上加空行,是分段落;换行,以两个空格结尾就可以实现换行。

org导出问题出在换行上,正常情况下,org导出markdown会在行尾自动添加两个空格,实现换行的。但是当在org中以中文字符结尾时,org导出功能就无法自动添加两个空格了。

目前,在网上看到的文章,大部分都是采用段落的方式(在org中添加空行)代替换行。
具体操作是在org中添加空行,导出markdown会保留空行。用段落代替换行。