Mac Air Mid 2011不支持系统升级,如何安装Xcode11?

Xcode是否可以通过什么途径,在低版本的系统上运行呢?

  1. 是否可以通过重签名Xcode来支持低版本系统?
  2. 再不济,是否在Xcode10上配置Xcode11的toolchain,来支持swift5等相关特性?

应该是不行,我之前想编译 https://github.com/apple/sourcekit-lsp 折腾了很久 Swift 5 都没成功,再看看旁边连 Ubuntu 14.04 的支持都没落下,为什么偏偏对自家那么苛刻。

逼着你换新机器啊

下了个ghc结果Xcode 11有bug:

https://trac.macports.org/ticket/59467

苹果迟早药丸

这也正是我最近回归 Linux 的心情日盛的原因。

除此,苹果在功能设计上也是异常的固执,例如手机的蜂窝开关也是到 iOS 12 才有的,MBP 取消 ESC 实体键(好像最近的 16 寸上又回归了),我等了很久的字典(iOS 上的查询,macOS 上的三指查询和右键 Look Up)接口至今也没有开放的迹象。

这也是我坚守 MBP 2015 的原因,当然,主要原因还是因为穷 :joy:

macOS 很多接口不会开放的,不过自己加一些词典也够用了,比如朗文

linux虽说标榜配置自由,但实际上有些配置改起来非常繁杂困难,或者干脆不可能。比如我之前想在linux上用mac快捷键,找了很久也没有完美的方案。现在就看苹果能sb到什么程度把我逼到linux。

由此看来,即使使用效果有时候没有封闭系统好,有free software存在还是很重要—至少你还有退路。

1赞