尝试全局关闭line-number失败

我用 emacsclient -t 启动 加入 (global-display-line-number-mode nil) 没任何反应,单m-x里面toggle两次可以关闭

求教!

(global-display-line-number-mode -1) 

不行的时候看对应函数的文档

If called from Lisp, toggle the mode if ARG is ‘toggle’.
Enable the mode if ARG is nil, omitted, or is a positive number.
Disable the mode if ARG is a negative number.

大神我照着你的改了,并没有成功。是不是emacs的daemon有时候不读取某些设置? 还有,请问如何让emacs在打开程序时显示行号,但是markdown或者org时不显示行号? 我是小白不是程序员,只能伸手要了。。。 谢谢!

成功了!确实是某些配置的问题,谢谢!

(add-hook 'prog-mode-hook (lambda () (progn (display-line-numbers-mode)

以后要在打开程序的时候干什么都可以扔进 (progn ) 里面。