【误 https://elpa.emacs-china.org/ 异常 】更新package cache 技能get

使用镜像更新插件一直提示失败

错误提示

Found 21 new package(s) to install...
--> refreshing package archive: gnu-cn... [3/3]
--> installing package: [email protected] [1/21]
An error occurred while installing bind-key (error: (file-error http://elpa.emacs-china.org/melpa/bind-key-20160227.48.el Not found))
--> installing package: [email protected] [2/21]
An error occurred while installing company (error: (file-error http://elpa.emacs-china.org/melpa/company-20161126.1629.tar Not found))
--> installing package: [email protected] [3/21]
An error occurred while installing company-statistics (error: (file-error http://elpa.emacs-china.org/melpa/company-20161126.1629.tar Not found))
--> installing package: [email protected] [4/21]
An error occurred while installing counsel (error: (file-error http://elpa.emacs-china.org/melpa/swiper-20161206.155.el Not found))
--> installing package: [email protected] [5/21]
An error occurred while installing counsel-projectile (error: (file-error http://elpa.emacs-china.org/melpa/swiper-20161206.155.el Not found))
--> installing package: [email protected] [6/21]
An error occurred while installing dumb-jump (error: (file-error http://elpa.emacs-china.org/melpa/dumb-jump-20161126.2045.el Not found))
--> installing package: [email protected] [7/21]
An error occurred while installing evil-mc (error: (file-error http://elpa.emacs-china.org/melpa/evil-mc-20161123.1318.tar Not found))
--> installing package: [email protected] [9/21]
An error occurred while installing helm-make (error: (file-error http://elpa.emacs-china.org/melpa/helm-core-20161206.2324.tar Not found))
--> installing package: [email protected] [10/21]
An error occurred while installing indent-guide (error: (file-error http://elpa.emacs-china.org/melpa/indent-guide-20160913.1754.el Not found))
--> installing package: [email protected] [11/21]
An error occurred while installing info+ (error: (file-error http://elpa.emacs-china.org/melpa/info+-20161127.1748.el Not found))
--> installing package: [email protected] [12/21]
An error occurred while installing ivy-hydra (error: (file-error http://elpa.emacs-china.org/melpa/ivy-hydra-20160517.1349.el Not found))
--> installing package: [email protected] [13/21]
An error occurred while installing link-hint (error: (file-error http://elpa.emacs-china.org/melpa/link-hint-20160412.2218.el Not found))
--> installing package: [email protected] [14/21]
An error occurred while installing neotree (error: (file-error http://elpa.emacs-china.org/melpa/neotree-20161124.739.tar Not found))
--> installing package: [email protected] [15/21]
An error occurred while installing open-junk-file (error: (file-error http://elpa.emacs-china.org/melpa/open-junk-file-20160912.1859.el Not found))
--> installing package: [email protected] [16/21]
An error occurred while installing org-plus-contrib (error: (file-error http://elpa.emacs-china.org/org/org-plus-contrib-20161118.tar Not found))
--> installing package: [email protected] [17/21]
An error occurred while installing persp-mode (error: (file-error http://elpa.emacs-china.org/melpa/persp-mode-20161119.505.el Not found))
--> installing package: [email protected] [18/21]
An error occurred while installing projectile (error: (file-error http://elpa.emacs-china.org/melpa/projectile-20161122.728.el Not found))
--> installing package: [email protected] [19/21]
An error occurred while installing swiper (error: (file-error http://elpa.emacs-china.org/melpa/swiper-20161206.155.el Not found))
--> installing package: [email protected] [20/21]
An error occurred while installing use-package (error: (file-error http://elpa.emacs-china.org/melpa/bind-key-20160227.48.el Not found))
--> installing package: [email protected] [21/21]
An error occurred while installing which-key (error: (file-error http://elpa.emacs-china.org/melpa/which-key-20161207.714.el Not found))

Found 3 orphan package(s) to delete...
--> deleting epl... [3/3]

更新为清华的镜像可以修复此问题

1 个赞

我没发现什么异常,你的 Package Cache 过期了而已。

package-refresh-contents 可以更新,让我们把它当作常识,不然的话,用 Melpa 和 Melpa-stable 这样不保留旧版本的 Package 的 ELPA 的话,差不多每天都遇到你所说的“问题”。

不清楚什么意思?清华的镜像的上游就是 https://elpa.emacs-china.org/

了解,多谢提醒

Emacs China ELPA 镜像中的 Melpa 和 Melpa-Stable 现在开始保留了旧版本了,这样的话,即便你的 Package Cache 过期了,应该不会出错了

更新为清华的镜像可以修复此问题

不清楚什么意思?清华的镜像的上游就是 https://elpa.emacs-china.org/

@woshipangbuo Sorry,请无视这个问题,我不是真想问,而且其实我大概能明白你的意思。