按github主页配置lsp-pyright出现问题

我按照lsp-pyright主页做如下配置:

(use-package lsp-pyright
  :ensure t
  :hook (python-mode . (lambda ()
                          (require 'lsp-pyright)
                          (lsp))))  ; or lsp-deferred

但是,每次打开python文件,mini-buffer都出现如下提示,不知道要怎么输入?: Unable to find installed server supporting this file. The following servers could be installed automatically:

必须先安装node/npm,使用 lsp-install-server 安装 pyright,或者直接 npm install -g pyright.

elpa里面已经装了lsp-pyright了,是不是在系统层面还要装一个pyright?debian里面直接apt install pyright可以吗?

是的。lsp-pyright 只是client,还需要能找到lsp server,就是pyright。