有没有感觉emacs29流畅很多很多?

刚去试了一下emacs-plus 和 emacs-head的29 版本。感觉快了很多啊

2 个赞

有!期待29.1的版本釋出!

是的。 可惜是很多package 在29 用不了。

是什么包用不了?去给包作者提 issue 啊!Emacs 29.1 这个月底就要切割了。

我这目前没遇到用不了 29 的包,可能是我用的包比较少。

这么快啊,tree-sitter好像还没合到主分支呀

tree-sitter 几个流行的 major-mode (如 cc-mode, python, sh, javascript/typescript ) 正在准备对 tree-sitter 的支持。弄好估计就合并了

最近用Emacs29遇到这个warning很是郁闷,好像persp-mode也不兼容了 :pensive:

⛔ Warning (emacs): Package ‘docker-tramp’ has been obsoleted, please use integrated package ‘tramp-container’

是什么 warning?

你才发现阿,刚出的时候我就用最新的了,直接把29.05的源加进来。用lsp也舒服多了。 还有就算ubuntu22.04是一个划时代版本的linux。也是顺畅舒服到爆炸。

月底啊,没几天了呀

⛔ Warning (emacs): Package ‘docker-tramp’ has been obsoleted, please use integrated package ‘tramp-container’

最近邮件列表有个主题讨论 docker-tramp, 你可以看看。现在已经直接加入29了,在 tramp-container.el

https://lists.gnu.org/archive/html/emacs-devel/2022-10/msg00208.html

我知道这个,但是docker.el 依赖于 docker-tramp。是不是因为通知docker.el 修改代码,而不是光给出一个warning更好?我给 docker.el报了一个issue。

这个确实很烦。完全没必要直接影响用户。

还有下面这个提示,很多包都受影响。

Package autoload is deprecated
1 个赞

兼容性问题真的让人非常痛苦啊, 这方面是不如vim.

如果能兼容26就好了.

为什么是26?

ubuntu22.04冲着LTS装过,默认使用snap,搞得我想要安装firefox不管是搜fireofx还是firefox-esr都没有,只能自己添加mozilla的源。这样强制推广snap让我有些不舒服。另外最近看到了报道说还在apt植入了ubuntu pro的广告。canonical实在让人有点难以有好感啊……

26功能比较全且稳定, 是我用过时间最长的版本, 从21到28, 最喜欢26

我也是遇到这个 Warning,比较烦躁。

我没注意勒,22.04+emacs29配合lsp,成功让我再次回到ubnuntu的怀抱成为我的主力系统。

看来真的只能商业化才能带来更好的用户体验。免费开源反而是最不好用,最贵的,BUG也多。 :rofl: