eaf安装时老是提示下载失败

我在终端里运行 ./install-eaf.py --install-new-apps总是出现错误: fatal: unable to access ‘https://github.com/emacs-eaf/eaf-file-browser.git/’: HTTP/2 stream 1 was not closed cleanly before end of the underlying stream

我网速太慢了吗?我感觉还可以啊,有时候测试下网速有几十M。我连的手机热点

连接Github有问题,可以用gitee镜像,加个--use-gitee

这样用吗?还是无法下载 ./install-eaf.py --install-new-apps --use-gitee

发个图给一看

GitHub - emacs-eaf/eaf-file-sender: Share file between Emacs and mobile phone
如果你这里访问不了上面的那个地址,那就是墙的问题了

或者你应该关掉emacs 不然系统可能因为文件使用中而拒绝更新文件也说不定

这次卡在了demo上。我怎么感觉还是网速的问题

demo可以不装的,选择性安装吧,如果一次装不完的话

你把app/文件夹删了重新跑一次

安装完了,还是什么也打不开。eaf buffer里的:

Traceback (most recent call last): File “/home/unicorn/.emacs.d/site-lisp/emacs-application-framework/eaf.py”, line 25, in from PyQt5 import QtWebEngineWidgets as NeverUsed # noqa ModuleNotFoundError: No module named ‘PyQt5’

Process eaf exited abnormally with code 1 Traceback (most recent call last): File “/home/unicorn/.emacs.d/site-lisp/emacs-application-framework/eaf.py”, line 25, in from PyQt5 import QtWebEngineWidgets as NeverUsed # noqa ModuleNotFoundError: No module named ‘PyQt5’

Process eaf exited abnormally with code 1 Traceback (most recent call last): File “/home/unicorn/.emacs.d/site-lisp/emacs-application-framework/eaf.py”, line 25, in from PyQt5 import QtWebEngineWidgets as NeverUsed # noqa ModuleNotFoundError: No module named ‘PyQt5’

Process eaf exited abnormally with code 1

你需要的是Python依赖

安装不了。啥情况?

我运行 /usr/local/bin/python3 -m pip install --upgrade pip pip版本升级到21.3.1。 可还是安装不上。

我遇到过类似的问题,或许可以参考参考

我是业余选手

这是经常出现的错误情况,我试过很多次都失败!!

事情是这样的,当我在 新 Windows 安装的时候,我安装了依赖使用上了 eaf-browser 并且没有错误

但是,在我不删除eaf的时候,我手动把 eaf-browser 依赖包删除了,结果再想使用,安装的时候出现跟你一样的情况,在之后我尝试把 python 删除了再来一遍,结果是同样的错误

所以,我怀疑是 python 的问题,或者是个人没有删除 干净依赖包的问题,反正我也解决不了

@manateelazycat