eaf打不开网页

我按照这篇文章的方法安装了EAF,EAF,我在emacs里M-x有eaf-open这些选项,但是不论是网页还是图片视频都打不开,一直显示opening。这是咋回事呢?

看看 *eaf* 报啥错?

[EAF/browser] Opening http://news.163.com
extmap 20200617.1905 available melpa Externally-stored constant mapping fo$|You can run the command ‘eaf-open-browser’ with M-x e-o-br RET he

是这个吗?

eaf-open-demo可以工作吗?

eaf-open-demo打不开

你是怎么安装,啥环境,详细说一下

我是emacs 27.1

1.终端运行 git clone --depth=1 -b master https://github.com/manateelazycat/emacs-application-framework.git ~/.emacs.d/site-lisp/emacs-application-framework/

2…/install-eaf.sh

3.安装 emacs-ctable,emacs-deferred,emacs-epc,s.el

4.init.el添加代码: (add-to-list 'load-path “~/.emacs.d/site-lisp/emacs-application-framework/”) (require 'eaf)

操作系统环境,桌面环境,窗口管理器分别是什么?

ubuntu 21.04,Gnome 3.38,

要安装xwayland

但是你啥都没反应,也没报错,不晓得啥问题

是不是在执行./install-eaf.sh过程中有错误?安装结束也没有说有什么错误,只是说没有pip,后来我又装了pip

  1. 是否升级了pip3 和 npm ? 安装前要先升级。
  2. 是否用其他包管理工具,比如 linuxbrew、conda, 安装过 Python3 ? 如果是,要改一下环境变量。可以把他们放在 $PATH 后面。conda 最新版默认是不激活的,可以不用管。

Gitee的mirror建议用这个

建议手动下载一下那些python 依赖试一试

我又运行了 ./install-eaf.sh 两遍,还是和以前一样。最后有5个警告

WARNING Compiled with 3 warnings 下午3:44:32

warning

asset size limit: The following asset(s) exceed the recommended size limit (244 KiB). This can impact web performance. Assets: js/chunk-vendors.525a66d3.js (708 KiB)

warning

entrypoint size limit: The following entrypoint(s) combined asset size exceeds the recommended limit (244 KiB). This can impact web performance. Entrypoints: app (720 KiB) js/chunk-vendors.525a66d3.js css/app.46b5b596.css js/app.7578d54f.js

warning

webpack performance recommendations: You can limit the size of your bundles by using import() or require.ensure to lazy load some parts of your application. For more info visit https://webpack.js.org/guides/code-splitting/

WARNING Compiled with 2 warnings 下午3:44:59

warning

entrypoint size limit: The following entrypoint(s) combined asset size exceeds the recommended limit (244 KiB). This can impact web performance. Entrypoints: app (253 KiB) css/chunk-vendors.98dca482.css js/chunk-vendors.1017a703.js css/app.7c7accd8.css js/app.b2f8f584.js

warning

webpack performance recommendations: You can limit the size of your bundles by using import() or require.ensure to lazy load some parts of your application. For more info visit https://webpack.js.org/guides/code-splitting/

我系统中Python有冲突,怎么解决?

下列软件包有未满足的依赖关系: python-dev-is-python2 : 破坏: python-dev-is-python3 但是 3.9.2-1 正要被安装 python-dev-is-python3 : 破坏: python-dev 破坏: python-dev-is-python2 但是 2.7.18-9 正要被安装 python-is-python2 : 破坏: python-is-python3 但是 3.9.2-1 正要被安装 python-is-python3 : 破坏: python 破坏: python-is-python2 但是 2.7.18-9 正要被安装 python3-clang-11 : 冲突: python-clang-x.y python3-clang-12 : 冲突: python-clang-x.y python3-clang-9 : 冲突: python-clang-x.y python3-cysignals-bare : 冲突: python3-cysignals-pari 但是 1.10.2+ds-5build1 正要被安装 python3-cysignals-pari : 冲突: python3-cysignals-bare 但是 1.10.2+ds-5build1 正要被安装 python3-lldb-11 : 冲突: python3-lldb-x.y python3-lldb-12 : 冲突: python3-lldb-x.y python3-lldb-9 : 冲突: python3-lldb-x.y python3-meep-mpi-default : 依赖: libmeep-mpi-default23 (= 1.17.1-2) 但无法安装它 python3-meep-openmpi : 依赖: libmeep-openmpi23 (= 1.17.1-2) 但无法安装它 python3-memoize : 冲突: python3-django-memoize 但是 2.2.0+dfsg-1 正要被安装 python3-paraview : 冲突: python3-vtk9 但是 9.0.1+dfsg1-8 正要被安装 python3-ptable : 冲突: python3-prettytable python3-ufo-extractor : 冲突: python3-extractor 但是 1:0.6-8 正要被安装 python3-vtk9 : 破坏: python3-vtk7 但是 7.1.1+dfsg2-9 正要被安装 python3-xattr : 冲突: python3-pyxattr E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

尝试 apt-get install -f ,不会修复依赖问题,就重装系统吧,我怀疑你根本没有把EAF的依赖装上去。

依赖列表里那几个核心依赖怎么装?

那几个核心依赖我系统里应该都装过了。我重新下载安装,依然如故。