doom-modeline 2.1.0

mode-line
doom
doom-modeline
elisp

#41

doom-modeline, 左下角会经常出现 这个字,这个问题是怎么解决的?我用的是macos下的emacs,安装了cnfonts。

知道方法了:init.el文件的修改如下:

;;(cnfonts-enable)      // 防止cnfonts自动启动

;; 如果用户觉得 cnfonts *太厚重*, 可以将下面
;; 一段 elisp 粘贴到 ~/.emacs 文件,然后保存,就不需要启
;; 动 cnfonts 来配置字体了。
;; -------

;; Auto generated by cnfonts
;; <https://github.com/tumashu/cnfonts>
(set-face-attribute
 'default nil
 :font (font-spec :name "-*-Monaco-normal-normal-normal-*-*-*-*-*-m-0-iso10646-1"
                  :weight 'normal
                  :slant 'normal
                  :size 15.0))
(dolist (charset '(kana han symbol cjk-misc bopomofo))
  (set-fontset-font
   (frame-parameter nil 'font)
   charset
   (font-spec :name "-*-Hiragino Sans GB-normal-normal-normal-*-*-*-*-*-p-0-iso10646-1"
              :weight 'normal
              :slant 'normal
              :size 18.0)))


//下面这段拷贝至上面的朋友 
 (defun +ng/better-font()
      (interactive)
      (if (display-graphic-p)
        (progn
          (set-face-attribute
           'default nil
           :font (font-spec :name "-PfEd-DejaVu Sans Mono-bold-normal-normal-*-*-*-*-*-m-0-iso10646-1"
                            :weight 'normal
                            :slant 'normal
                            :size 9.0))
          (dolist (charset '(kana han symbol cjk-misc bopomofo))
            (set-fontset-font
             (frame-parameter nil 'font)
             charset
             (font-spec :name "-ADBO-思源黑体 CN-light-normal-normal-*-*-*-*-*-*-0-iso10646-1"
                        :weight 'normal
                        :slant 'normal
                        :size 11.0))))))

    (defun +ng|init-font(frame)
      (with-selected-frame frame
        (if (display-graphic-p)
            (+ng/better-font))))

    (if (and (fboundp 'daemonp) (daemonp))
        (add-hook 'after-make-frame-functions #'+ng|init-font))

谢谢楼上朋友的提示,谢谢。


#42

doom-emacs, 平时显示icon正常,但是当使用leader key 唤出底部菜单时,icon便显示乱码。 这是bug吗?


#43

本地测试没有这个问题。你可能需要问下doom-emacs.