Doom Emacs只能用Vim模式吗?

能不能换成Emacs输入模式?没找到像Spacemacs那样的 M-m t E 设置

C-z就可以切换到emacs模式,也有对应的leader

1 个赞

(setq evil-default-state 'emacs) 打开文件默认开启emacs模式

2 个赞

还有一个问题,它还有打开终端的快捷键 SPC o t ,但我安装后提示这个命令 undefined。为什么?

参见页面描述:https://github.com/hlissner/doom-emacs/tree/develop/modules/config/default

I’m not an evil user…
That’s fine. All evil configuration is ignored if :editor evil is disabled.

这个视频系列讲Doom挺不错,要翻墙: https://www.youtube.com/watch?v=Rx3wRl5d-J0&list=PLhXZp00uXBk4np17N39WvB80zgxlZfVwj

1 个赞

棒…

先看看你的环境满不满足文档的需要:https://github.com/hlissner/doom-emacs/tree/develop/modules/term/vterm#prerequisites

还要加一行这个,不然进入org模式会自动回到evil模式 (after! org (setq evil-normal-state-modes nil))