[求助] Archlinux 无法运行blender

Archlinux安装blender, 程序运行之后,界面无法正常操作,鼠标点击界面,界面就疯狂的闪烁。

电脑:Thinkpad X1 Carbon 5gen wm: i3

找了很多资料没有办法解决,只好在这里求助了。。。

1赞

blender似乎2.8之后对显卡有要求,我的稍微老一点的电脑就运行不了,不过你这个配置应该没问题,显卡驱动的问题?

我也怀疑室显卡驱动的问题,感觉跟gpu有关系,好几个跟GPU有关的软件运行都不正常,其他程序运行都正常。但不知道从哪里下手。

先按archwiki重新安装一遍显卡驱动,把正确的驱动装上,然后看看是不是内核的问题,我记得前几天arch新闻还说5.9 linux内核跟N卡驱动不兼容来着,,可以试试降版本或者换lts内核

一通乱折腾,改了这个参数之后就好了:

/etc/X11/xorg.conf.d/20-intel.conf

   Option "TearFree" "true"
   Option "AccelMethod"  "uxa"