Windows10下Emacs只要有中文就非常卡

嗯,我换24.5试试看。谢谢啦。

换24.5也没有改变,卡滞情况会好一点点,但是并没有意义…情况和25基本一致…

如果是 win10 的话,推荐使用 ubuntu 下面的 emacs。 win10 不是集成了 ubuntu 吗?

或者直接用 mac 或者 linux,emacs 在 windows 上本来问题就多。。。

嗯,我打算用ubuntu下的Emacs了…

我感觉是Bug:Emacs在Windows下用-Q启动,显示中文就卡,而改过字体就没事了。

1赞

改了字体真的解决了:joy:换成微软雅黑就一点也不卡了…奇怪…

稍微看了一下,是因为Emacs默认选择了BatangChe这个韩文字体显示中文,明显会导致问题,不停的fallback,所以卡。我现在是没有时间/动力研究这个了,改个字体就好了。

:smirk:我还有很多在Windows下折腾Emacs的经验哦

1赞

还真没注意,我一般是Source code+雅黑,没有卡顿的问题。

原来是这个原因,以后求多多指教~

我也是用Windows 10,emacs-bin-w64-25.0.94-O2.7z, 200k 左右的中文文档,卡得很,用swiper搜索很容易卡死。已经设置了Fundamental mode,不知道有没有办法解决。上传中…

建议您另外开帖询问,因为我不用这些工具,不知道是否和楼主说的情况一致。一个问题很好奇:是有中文的时候才卡,还是中文英文都卡?

呵呵,学习了~~~

Source code+雅黑, 是怎么做到的? 原来能中英文字体独立配置, 请指教~

看这个2楼

谢谢. 确实用上了, windows下的emacs打开中文文档流畅了很多. 用了同帖子的另一个方法:

CSDN上找到了答案,以后遇到这个问题的可以去尝试下这个方法

解决: 打开菜单Options->Set Default Font,将字体改为宋体。 然后再回到Options菜单,点Save Options。这一步可千万别忘了,否则,关闭窗口后,重新打开又会出现同样的症状。

摘自:https://blog.csdn.net/hongweigg/article/details/54615292

2赞

我也出现过,我的是GC的问题,解决方法:

应该是编码的问题

谢谢 解决了

https://blog.csdn.net/grey_csdn/article/details/79080472

这篇文章有一个设置默认字符编码的思路,可以考虑尝试。

1赞