在spacemacs中org的agenda失效

哦 谢谢 ~~~ 但是我这个值查询是正常 但是 会 报出 一个 org-at-planning-p 不存在的错误~ 这个值是没有关系的吧

你可能没正确配置org,spacemacs 用的是最新的org,如果你添加配置不正确会导致自带的org 被启用,运行下 org-version 看看。

Org-mode version 8.2.10 (release_8.2.10 @ /Users/zhouzihao/.emacs.d/elpa/org-plus-contrib-20170210/)

这个 201702108.2.10 似乎不匹配?有没有可能你混用的俩个 Org 版本,比如你先加载 8.2.10 的 Org,但随后又需要用 20170210 的 Org。

(require 'org)                          ; 8.2.10

(package-initialize)
(package-install 'org)                  ; 20170210

那怎么处理呢??

(with-eval-after-load 'org ...)把你的配置包起来。

好的 我试试~

Ho no ~依旧不行:joy:

Org mode version 9.0.5 (9.0.5-elpa @ /Users/apple/.emacs.d/elpa/org-20170210/)

你可能真的用了假的 Org,检查一下你有没有用别人的配置(你用的似乎是别人的Org修改版本)。


以防万一,确认你用了最新的 Spacemacs。

我使用的是 最新的develop分支啊~

老老实实用 master 吧。鉴于 develop 的可靠性未知。

嗯 我下班了 切回去试试

切换回master问题解决 但是原因 依旧不详~谢谢 大兄弟:grin:

找到了问题的原因。

原因是Spacemacs有一个叫做 org-plus-contrib 的包,是个能使 spacemacs-orgorg 两个 Layer 同时对org进行配置的黑科技,本质上就是 org.el。在没有开启 org Layer 的时候,Spacemacs用的就是这个包。 但是启动时错误加载这个包会导致一些函数没有被正确定义,比如出现下面的错误:

File mode specification error: (void-function org-link-types)

为什么在 Dev branch 会出错呢?

issue里面有解释,最新版想要解决原先 可能 不能正确加载最新版org的bug,结果和原先的org Layer起冲突导致问题依旧存在,导致的题问中的Bug。似乎重新编译相应的包能解决。现在已经有提出相应的Fix,等待审理。

但是babel之类的功能在 develop brach 不能正确生效,需要重新配置。所以还是用 master吧。

现在解决了吗! 我用了 这个 org-depend.el ,就总出现同样的错误提示

没有啊,我在用 develop branch,org babel 每天都在用没有问题,org 是最新版本的 org-plus-contrib

@zhua 我发帖以后很快就修复了…… 而且发帖的时候已经开始修复了。

现在我也用了devlop。

那可能是我个人的问题了,多谢两位!

spacemacs org-mode 无法执行代码块 还是这个最暴力,但也有效!:sweat_smile: 是没有更新最新版的 org-plus-contrib, 目前没问题了,因我是正在试用 “org-depend.el” 中的 TODO 来 “:TRIGGER: chain-siblings(NEXT)”

该问题目前有结论了吗? 新安装spacemacs, 还是复现了. master分支.