有升级了macOS Mojave的朋友吗?Emacs还能不能正常使用了?

可以使用,但railwaycat版本的emacs不能用了,我用的官方的。

我的emacs-plus(vanilla)版本没问题

因为Mojave默认把抗锯齿关了……

嘤嘤嘤,我用的 emacs-plus 遇到问题了,reddit 上也有人遇到,参见

https://www.reddit.com/r/emacs/comments/9iu5vd/error_when_opening_up_emacs_and_wont_open_file/

官方的版本一切正常

我用的是 railwaycat 版本的,并且重装了,目前使用良好。

brew tap railwaycat/emacsmacport
brew install emacs-mac --with-natural-title-bar

重新编译了+1

AppleScript 支持还能用么?请问有人试过没?

(do-applescript "display dialog \"Hello World\"")

我在用 emacs-plus 版本, 可以用 Apple script。

1 个赞

emacsmacport 可以

emacsmacport 官方编译版本跪了

做开发的同学可以下决心迁移到linux了,你们已经不是苹果的目标客户了.

今年库克都没急着让你们更新,你们怎么都这么急。

自从Steve童鞋给上帝造mac之后,再也不敢第一时间升级了 :frowning:

系统范围的抗锯齿还可以再打开,但好像作者的更新说明里说换了emacs-mac的渲染方式后就不能再用抗锯齿了,老爷机看那种毛茸茸的字体简直受不了。。

为什么不是目标用户啦?

今天推了更新,Emacs 的问題解決了,Command Line Tools 用 xcode-select --install 重装下就好了。別的沒有大问題。哦,Common Lisp 的 roswell 的 CCL 好像挂了,不過我果然還是覚得不如不用。

完全没有问题,brew 和 brew cask 安装都能用。

我的emacs 在新mac系统下没法保存字体。修改后,保存设置,重启后又恢复了。