升级到lsp-mode 6.3之后, emacs报错, 函数s-replace-regexp无效

在最新版s.el里搜了一下没有. 用包管理安装了一下lsp-mode, 依然没有这个函数定义.

这个函数定义在哪里?

https://github.com/magnars/s.el/blob/master/s.el#L377

原来如此, s.el近两年没更新, 但是正式版竟然不是最新版. 我一般只安装正式版.

lsp-mode的包依赖里没有s.el, 所以用package安装也安装不了最新s.el.

另外, flycheck也是两年没出正式版, 还有markdown-mode, 不知道他们是怎么计划的.

lsp-mode 6.3.1 里 s-replace-regexp 已经换成了 replace-regexp-in-string

没想到竟然因为这个又出了个版本.