如何编译 irony-server?

看见官说要编译irony-server,不知道这个要怎么弄

https://github.com/Sarcasm/irony-mode#usage

On the first run, irony-mode will ask you to build and install irony-server. To do so, type M-x irony-install-server RET.

刚刚试了下:第一句话好像不对,第二句话没问题。

– Check for working C compiler: /usr/bin/cc – works – Detecting C compiler ABI info – Detecting C compiler ABI info - done – Detecting C compile features – Detecting C compile features - done – Check for working CXX compiler: /usr/bin/c++ – Check for working CXX compiler: /usr/bin/c++ – works – Detecting CXX compiler ABI info – Detecting CXX compiler ABI info - done – Detecting CXX compile features – Detecting CXX compile features - done – Setting build type to ‘Release’ as none was specified – Performing Test HAS_STDCXX11 – Performing Test HAS_STDCXX11 - Success – Performing Test HAS_CXX11_STDLIB – Performing Test HAS_CXX11_STDLIB - Success – C++11 compiler option(s): -std=c++11 CMake Error at /usr/local/share/cmake-3.6/Modules/FindPackageHandleStandardArgs.cmake:148 (message): Could NOT find LibClang (missing: LIBCLANG_INCLUDE_DIR) Call Stack (most recent call first): /usr/local/share/cmake-3.6/Modules/FindPackageHandleStandardArgs.cmake:388 (_FPHSA_FAILURE_MESSAGE) cmake/modules/FindLibClang.cmake:89 (find_package_handle_standard_args) src/CMakeLists.txt:3 (find_package)

后面有说用rpath指定目录 ,但我安装的clang没有头文件是用yum安装 的

再安装了个devel好了,包含头文件,只有系统的clang的版本有点低为3.4.用源码包安装时报错了