doom-modeline - 源自doom emacs 的 mode-line

mode-line
doom

#61

你用的最新版本吗?应该随时加载都生效才对。

mu4e-alert-enable-mode-line-display 放到 hook 里生效,不是因为 advice ,是因为use-package 里我默认设置了(setq use-package-always-defer t)


#62

谢谢!刚看了一下,应该是最新版本,melpa上的,20190301.1806。

还是我上面说的情况,默认是 mu4e-alert 自带的提示,并且message buffer里面有报错: (eval (doom-modeline-segment--mu4e)) signaled (wrong-type-argument number-or-marker-p #(" Mail [1] " ..... ),这应该是因为mu4e-alert-mode-line的格式不对。看样子 doom-modeline-override-mu4e-alert-modeline 并没有被执行。

我在 doom-modeline-mode-hook 里面加上 mu4e-alert-enable-mode-line-display 就好了。

edit: 不好意思,没仔细看代码,doom-modeline-override-mu4e-alert-modeline 里面有 (bound-and-true-p doom-modeline-mode) 这个条件,所以要在 doom modeline mode 激活之后才行,这下搞明白了。


#63

确实还是有 bug,我又更新了下。


#64

谢谢,目前没发现什么问题。


#65

为什么我用modeline显示不了字数?使用evil的搜索功能时也没有显示有多少个可选项?是不是有些包没有使用?


#66

doom-modeline 只需要evilevil-anzu


#67

谢谢,问题解决了


#68

今天收到个好消息,doom-emacs 作者已经在开发分支中直接集成了doom-modeline


#69

刚刚更新了最新的doom-modeline,然后重新启动就给我弹出error了…

Error (use-package): doom-modeline/:config: Buffer does not seem to be associated with any file

我的配置在这里,启动emacs的时候自动进入dashboard,下面modeline显示的file是/emacs-26.1-x86_64/bin/ 不知道是哪儿出了问题


#70

最近有人遇到类似的问题,正在调查。


#71

Fixed now.


#72

话说问一个问题。我正在研究你的init.el文件,你为什么在第一行设置no-byte-compile: t; ?根据我的理解,byte-compile不应该会使文件运行的更快吗?


#73

经过测试,byte-compile 配置文件没有多大性能提升,反而会带来很多弊端。