在 doom emacs 里, elfeed 应该如何设置 socks5 代理的?

在网上搜了半天, 一头雾水, 不明就里. 请哪位有空帮忙指点一下.

我通常先在终端里面走代理之后再doom s/env 这样magit push 到GitHub也走代理,类似里面的 allproxy方法

多谢多谢, 这个页面也搜到了. 只是看不明白. 另外, 照抄一个网友的配置, 现在已经测试成功了.

(setq elfeed-curl-extra-arguments '("-xhttp://127.0.0.1:1080"))

不过,不想用http代理, 还是更愿意用socks5代理, 不知道应该把上面这句怎么改一下.

直接搜索代码 https://grep.app/search?q=elfeed-curl-extra-arguments

这个方法不错. 找到一堆, 照抄了其中一段:

 (use-package elfeed
   :disabled
   :ensure t
   :commands elfeed
   :config
   (setq elfeed-curl-extra-arguments '("--proxy" "socks5://127.0.0.1:1080"
                                       "--retry" "3"
                                       "--insecure"))

测试一下, 有很多feed拿不到, 提示说

似乎是https都拿不到. http就有些拿不到. 不知道为什么.

换成http代理, 就一切正常.

应该还是配置上有什么问题吧. 暂时先用http代理好了.

试试 dochang/mb-url, 使用 curl 作为后端,支持全局 socks5 代理。可以参考我的配置 opsnull/emacs

多谢多谢. 很有启发. 我再去试试.