更新到最新版本counsel-rg使用报错


#1

之前使用一直正常,今天更新了一下counsel包到最新版本(20190312.1918) 在使用counsel-rg时,报错信息如下 counsel–find-project-root: Wrong type argument: stringp, nil 大家有遇到这种情况吗,特意试了一下另一个包rg.el,使用也是正常的。 下面是更详细的出错信息 20190313123138


#2

我这里没有遇到,macOS + GNU Emacs26.1


#3

非常感谢,昨天把这个情况提交了issue,刚好之前 basil-conto 好像提交了一批更新待审核其中有一个就是我遇到的问题,今天把counsel.el升级到最新版本得到了解决,issue地址。 另外请问您一下,您那边有没有最新ripgrep1.10的windows gnu版本,昨天一直下载不下来,不知道是不是我这边的宽带运营商受到了限制。


#4

我没有使用Windows,所以不清楚哈。翻墙试试就知道了